Connecter la carte Mini2440 sur un réseau Wifi

Maintenant que vous savez connecter la Mini2440 sur votre réseau local, vous êtes en mesure d’y accéder via Telnet et d’envoyer des fichiers via FTP. Mais la Mini2440 étant destinée à être embarquée dans un robot mobile (Geeros), on la voit mal restée branchée à un routeur via un câble Ethernet. Nous allons donc ici lui permettre de rejoindre un réseau Wifi.

Avant de décrire les différentes étapes, vérifions tout d’abord si les outils Wifi sont installés sur votre carte (a priori non). Exécutez la commande « scan-wifi ». Si vous avez en retour « -sh: scan-wifi: not found », cela signifie que vous devez installer le kit Wifi, usb-wifi-kits-for-mini2440-linux-2.6.32.2-20100728.tar.gz.Vérifiez avant que votre version de Linux est bien linux-2.6.32.x (« cat /proc/version »).

Pour cela, vous allez télécharger le fichier sur la Mini2440 en utilisant un client FTP sur votre ordinateur. Mais avant tout vous devez spécifier un mot de passe au compte utilisé sur la Mini2440 (par défaut: root). Après connexion en telnet à, par exemple, ce compte root, créez un mot de passe avec la commande « passwd ».

Vous pouvez maintenant envoyer en FTP l’archive sur la carte. Décompressez-là ensuite avec la commande suivante:

 

tar xvf usb-wifi-kits-for-mini2440-linux-2.6.32.2-20100728.tar.gz

 

 

 

Avant de ré-exécuter la commande « scan-wifi », redémarrez la Mini2440 et connectez une clé USB Wifi sur le port hôte de la carte. Attention: toutes les clés ne sont pas supportées, loin de là. J’ai personnellement utilisé ce très bon modèle: TP-Link – TL-WN722N. Son antenne permet en particulier d’avoir une très bonne portée ce qui est important pour un robot mobile.

Vous pouvez maintenant exécuter les commandes suivantes:

  • Recherche des réseaux Wifi à proximité:
     

    scan-wifi
  • Connexion en Wifi au réseau de votre choix (en mode WPA2 dans l’exemple ci-dessous)
     

    start-wifi wpa2 essid_de_votre_reseau mot_de_passe_de_votre_reseau

Après cette dernière commande, l’adresse IP de la carte est assignée automatiquement via DHCP.
Si vous souhaitez la définir vous même, utilisez la commande suivante:

 

ifconfig wlan0 192.168.43.199

 

 

Remarque importante: la carte Mini2440 est alors connectée à votre réseau Wifi en mode « managed », c’est-à-dire comme (a priori) vos autres clients Wifi. Deux autres modes pourraient être utiles:

  • Ad-hoc: dans ce cas, la Mini2440 servirait de point d’accès et vous pourriez y connecter directement un ordinateur ou un iPhone, mais pas un smartphone Android, cet OS ne supportant pas (à l’heure de l’écriture de ce billet, espérons que ça change dans le futur) les réseaux Ad-hoc
  • Master: ici, c’est la Mini2440 dans sa configuration de base qui ne supporte pas ce mode

 

pissavin gerard

Bonjour,
Je suis lycéen en prepa math spé et je commence un projet robotique. J’ai connecté ma carte mini2440 sur le réseau local sans aucun problème. j’utilise putty en mode telnet pour piloter ma carte.Je compte y installer les librairies QT. Par contre je ne réussi par à la connecter en wifi. J’ai utilisé filezilla client depuis win7 pour télécharger le fichier usb-wifi-kits-for-mini2440-linux-2.6.32.2-20100728.tar.gz que j’ai décompressé.
Avec mes économies j’ai acheté la clef USB TP-link TL-722N pour mettre toutes les chances de mon côté. La commande start-wifi se passe bien et trouve le point d’accès de mon routeur livebox. Mais après c’est fini je ne peux pas me connecter, j’ai tout essayé en wpa2 en wep et meme sans cryptage je n’arrive pas à me connecter. J’ai lu quelque part que cette clé USB est forte consommatrice de courant est-ce la le pb?. Ce serait sympa de dépanner un pov lycéen très studieux et future citoyen. Merci d’avance.
Nota:
J’ai pas de pb de connexion avec ma livebox car j’ai 5 PCs que j’ai tous connecté sans pb et en plus une vieille sparc SS20 avec 4 processeurs que m’a refilé mon père (j’ai installé debian dessus) qui me sert de serveur de calcul dans une ferme de calcul parallèle car je me passionne pour la simulation des phénomènes scientifiques.

admin

Bonjour,

Peux-tu m’envoyer le résultat des commandes suivantes:
– scan-wifi
– start-wifi wpa2 essid_de_ton_reseau mot_de_passe_de_ton_reseau (ou équivalent si tu es en wep ou ouvert)
– ifconfig

D’ailleurs, à ce sujet, si j’ai bien compris tu es connecté en Ethernet pour exécuter ces commandes. Exact ? Si oui:
– as-tu essayé via une console série ?
– qu’est-ce qui te permet de dire que tu n’es pas connecté en Wifi ? (ton routeur Wifi est différent de ton routeur filaire ?)

A part ça, quelle alim (tension, puissance) utilises-tu pour alimenter la carte ?

Merci,

Nicolas

gege15

Bonjour;
Voici point par point les réponses à tes questions:

#scan-wifi
cfg80211: calling CRDA to update world regulatory domain
usbcore: registered new interface driver rt73usb
usb 1-1 : ath9k_htc : trabsfered FW : ar9271.fw, size: 51280
usb 1-1 : ath9k_hc: HTC initialized with 33 credits
cfg80211: calling CRDA for country: CN
registered led device: ath9k-phy0::radio
registered led device: ath9k-phy0::assoc
registered led device: ath9k-phy0::tx
registered led device: ath9k-phy0::rx
usb 1-1: ath9k_htc:USB layer initialized
ubscore: registered new interface driver ath9k_hif_usb
63% Livebox-34d0 (Security)

#start-wifi wpa2 livebox-34d0 « xxxxxxxxxxxxxxxxxxxxxxxxxxxxx
udhcpc (v1.13.3) started
sending discover…
sending discover…
sending discover…
sending discover…
sending discover…
sending discover…
sending discover…
sending discover…
sending discover…
sending discover…
………..etc……………..
……………………………

le serveur DHCP ne répond pas. (à la demande du dongle USB wifi TL-WN722N « sending discover »):
Le serveur devrait répondre par un paquet DHCPOFFERT pour soumettre une adresse à la carte.
Pourquoi le paquet DHCPDISCOVER n’atteint pas le serveur DHCP de la livebox????

#ifconfig
eth0 Link encap:Ethernet HWaddr 08:90:90:90:90:90
inet addr:192.168.1.230 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:51 Base address:0x4300

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wlan0 Link encap:Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

#iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bgn Mode:Managed Access Point: Not-Associated
Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off

Ces commandes ont été exécutés avec la console série.
Mon routeur est unique (filaire et wifi: livebox).

j’avais aussi essayé de faire la connexion wifi connecté sur ethernet
(j’ai fait 36 fois l’essai par divers méthodes avec wpa_supplicant sans succès)
j’ai changé de dongle usb en prenant ce que j’avais dans mon stock TL-WNT321G)

Je ne suis pas connecté en wifi :
– car le dhcp ne m’a pas attribué d’adresse
– et il m’est impossible d’atteindre mon routeur et ma station de travail (avec un ping)
– la commande iwconfig m’indique qu’il n’y a pas d’association avec le point d’accès

L’alimentation était fournie avec la carte (5v 2 ampères).

La configuration de la livebox ne semble pas en cause! vu le nombre de machines et imprimantes
que j’ai installées en wifi wpa2.

gege15

Bonjour Admin,

J’ai résolu mon problème.
Pour que cela serve à d’autres voici la solution.
J’ai constaté que la commande start-wifi était en réalité une commande intermédiaire créant un fichier de configuration /etc/wpa.conf passé en
paramètre à la commande wpa_supplicant (bien connue du monde linux) avant de la lancer.
j’ai donc fait appel directement à la commande wpa_supplicant en créant avec vi le fichier de configuration
/etc/wpa_supplicant.conf dans lequel on retrouve entre autre:
– le ssid
– le mode de cryptage
– la clé
Pour que cette commande soit instrumentée, afin d’avoir un retour sur son comportement, j’ai activé le mode
debug avec l’option -dd.
wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf -dd
L’instrumentation de cette commande m’a permis de découvrir la raison de mon erreur.
Il s’agissait tout simplement du code de la clé qui doit être mis entre guillements ???
Ce qui donne par exemple:
start-wifi wpa2 Livebox-34d0 « 57842159632587412 »
Que de temps passé pour si peu de choses!!
Pour que la connexion wifi soit automatique au démarrage de la carte Mini2440 j’ai ajouté la commande start-wifi à la fin du fichier
/etc/init.d/rcS (Ce fichier est appelé par le processus init au démarrage du noyau )
Tout fonctionne parfaitement.

Et Merci encore pour votre disponibilité.

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *